Por fin funciona la ATI xpress 200m

Despues de mucho batallar para que funcionara la aceleración gráfica en la ATI xpress 200m de la laptop zv6000 encontre el problema.., faltaba desactivar el drm que viene en el kernel del ubuntu dapper… así que le agregue al menu.lst del grub el siguiente parametro nodrm

Y bueno, la instalación la hice como dice en casi todos los howtos que estan en internet.

0.- Entrar al BIOS y cambiar el la seccion de memoria donde dice Sideport a UMA+Sideport y ponerle 128M tanto para UMA como para Sideport

1.- Te bajas el driver de ATI (para amd64) –> ati-driver-installer-8.23.7-x86_64.run

2.- Desinstalas todo lo referente al fglrx que viene con ubuntu

sudo apt-get remove xorg-driver-fglrx
sudo apt-get remove fglrx-control
sudo apt-get remove linux-restricted-modules-$(uname -r)

3.- Configuras tu xorg.conf para que tome el driver ati en lugar del fglrx (sino cuando reinicies linux no entra al gdm), así que ponemos el comando y seleccionamos ati

sudo dpkg-reconfigure xserver-xorg

4.- Borramos tambien las fuentes del fglrx

sudo apt-get –purge remove fglrx-kernel-source
sudo apt-get –purge remove fglrx-kernel-$(uname -r)

5.- Compilamos el nuevo driver de ATI

sudo apt-get install gcc-3.4 module-assistant build-essential fakeroot dh-make debconf libstdc++5 gcc-3.3-base
chmod +x ati-driver-installer-8.23.7-x86_64.run
sudo sh ./ati-driver-installer-8.23.7-x86_64.run –buildpkg Ubuntu/dapper

Y checamos la carpeta /tmp ahi vamos a tener los .deb creados :-) ahora sigue instalar

sudo dpkg -i xorg-driver-fglrx_8.23.7-1_amd64.deb
sudo dpkg -i fglrx-control_8.23.7-1_amd64.deb
sudo dpkg -i fglrx-kernel-source_8.23.7-1_amd64.deb

Y compilamos el modulo con module-assistant

sudo module-assistant

Esto nos abre un dialogo de texto y seguimos la siguiente secuencia.
– PREPARE
– UPDATE
– SELECT
– Marcamos fglrx-kernel
– BUILD
– NO
– INSTALL

O si se hacen bolas con estos pasos nomas pongan:

sudo m-a prepare
sudo m-a update
sudo m-a a-i fglrx

Despues si todo va bien ya tenemos el driver compilado y cargado en el kernel :-) , ahora falta cambiar el xorg.conf de ati a fglrx :-P

sudo aticonfig –initial

Aunque sigo con un pequeño problemita!.., ya que en ratos la chompu se traba!…, pero jeje, ya por lo menos reconoce que tengo el opengl activado.

Fuentes:
* http://ubuntuforums.org/showpost.php?p=423584
* http://wiki.cchtml.com/index.php/Ubuntu_Installation_Guide
* http://ubuntuforums.org/showthread.php?t=76116

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *