Joomla: Error de codificación de contenido

Si les llega a suceder en Joomla (o Mambo) el siguiente error:

Error de codificación de contenido
La página que intentas ver no puede mostrarse porque usa una forma de compresión no válida o admitida.
Contacta a los propietarios del sitio web para informarles sobre este problema.

La solución es deshabilitar la compresión de las páginas con gZip, entonces en el archivo de configuration.php buscamos la linea $gzip y le ponemos valor 0.

public $gzip = ‘0’;

Listo!! reiniciamos la página web de joomla y todo normal.

Leer y escribir particiones Linux ext2 y ext3 en Windows (2k, XP, Vista y Win7)

Si tienes linux y windows en la misma computadora compartiendo el disco duro, y pues por desgracia windows no puede leer las particiones de linux de forma nativa, pero gracias a Ext2Fsd nos soluciona este problema, podemos leer particiones ext2 y ext3 de forma nativa (es decir, aparecerá la unidad en Equipo, al lado de C: )

Debemos descargar Ext2Fsd de: http://www.ext2fsd.com la versión más nueva es la Ext2Fsd 0.51

Una vez instalada (con privilegios de administrador), procedemos a la configuración.
Aparecerá un listado de las particiones, pero antes de hacer cualquier cosa, si no reiniciamos la computadora con la instalación debemos de activar el servicio: Tools > Service Management (F7) y pues le damos start

Una vez iniciado el servicio procedemos a agregar el nombre de la unidad y que se monte automaticamente, para eso en la lista botón derecho > Change Drive Letter (F4), despues agregar y seleccionar la unidad que deseamos y listo!!.

Y listo!!! ya tenemos la partición montada.

Wifite, Obtener claves WEP y WPA desde Linux

Si estas cansado de probar manualmente los programas aircrack, airodump y otros para obtener claves WEP o WPA pues ahora ya contamos con un software que automatiza todo el proceso, se llama Wifite, es un script escrito en python-tk.

Alguna de las características son:

  • Ordena los objetivos por dB, así tenemos el más cercano al inicio de la lista
  • Automáticamente desauntentifica clientes para las redes ocultas
  • Filtros, por señal, canal, wep,wpa…
  • Caracteristica de anonimato, gracias al cambio de la MAC address
  • Automatización del ataque
  • Pone nuestra tarjeta de red en modo monitor, soportando el chip intel 4965
  • Auto actualización…, entra más monerias

Antes de instalar el script es necesario instalar los siguientes programas:

aircrack-ng
python-tk
macchanger
pyrit

Y luego para instalar wifite deben usar estos comandos:

wget -O wifite.py http://wifite.googlecode.com/svn/trunk/wifite.py
chmod +x wifite.py
sudo ./wifite.py

Y listo!!! marcar los filtros deseados y luego el botón rojo “h4x0r 1t n40”

BleachBit, Limpieza de Linux

BleachBit es una aplicación que nos permite eliminar archivos obsoletos y así tener más privacidad en nuestro querido Linux y el no tan querido pero usado Windows, algo como el famoso CCleaner

Y como siempre tan facil para instalarlo en Ubuntu Linux con ejecutar (o de aquí lo pueden descargar):

apt-get install bleachbit

Alguno de los programas que eliminar son:

  • Adobe Reader
  • aMSN
  • Bash
  • Chromium
  • emesene
  • Epiphany
  • Evolution
  • Exaile
  • Filezilla
  • Firefox
  • Flash
  • gedit
  • gFTP
  • GIMP
  • GNOME
  • Google Chrome
  • Google Earth
  • Google Toolbar
  • Internet Explorer
  • Java
  • KDE
  • Konqueror
  • Microsoft Office
  • MySQL
  • Nautilus
  • OpenOffice.org
  • Opera
  • Safari
  • Skype
  • TeamViewer
  • Thumbnails
  • Thunderbird
  • VLC media player
  • Windows Explorer
  • Silverlight
  • WinRAR
  • WinZip
  • Yahoo! Messenger
  • Zsh

Uffff!! y faltaaan!. bueno aquí pueden ver todas las características del programa BleachBit

coWPAtty

¿Que es coWPAtty?

Nos permite desencriptar contraseñas mediante el uso de diccionarios, ya sea para descubrir alguna clave WPA, o como dice Joshua Wright

“coWPAtty is designed to audit the pre-shared key (PSK) selection for WPA networks based on the TKIP protocol.”

Para instalar, necesimos descargar de http://wirelessdefence.org/Contents/coWPAttyMain.htm aquí la versión de coWPAtty 4.6

Y asegurarnos tener instalado lo siguiente:

apt-get install libssl-dev libpcap-dev libdigest-hmac-perl

Despues:

tar zxvf cowpatty-4.6.tgz
cd cowpatty-4.6
make

Y para finalizar

aptitude install build-essential

Ahora si a ejecutar ./cowpatty

Igual si queremos que este disponible para cualquier aplicación y lugar en Linux de forma facil solo copiarlo a /usr/bin

cp cowpatty /usr/bin

nginx – error 413 Request Entity Too Large

Hoy por la mañana queria subir un archivo CSV al servidor pero lo hago mediante 2 pasos, primero cargo el archivo y muestro un formulario con los resultados para confirmar que la información sea correcta, despues ese formulario lo mando mediante POST y al darle enviar me aparece el siguiente error en el servidor web Nginx

Error 413 Request Entity Too Large

La solución a todo esto es aumentar el tamaño en Megas que puede recibir el servidor., solo es cosa de modificar el archivo /etc/nginx/nginx.conf o si tiene subdominios la carpeta correspondiente al subdominio que estara dentro de /etc/nginx/sites-available/default (por ejemplo)

Bueno ahí dentro del archivo de configuración buscamos el bloque server e insertamos adentro la etiqueta: client_max_body_size 50M; (en donde 50M es el tamaño deseado), nos quedaría algo así:

server {

listen 80; ## listen for ipv4
listen [::]:80 default ipv6only=on; ## listen for ipv6

server_name paginaweb.com www.paginaweb.com;
client_max_body_size 50M;
access_log /var/log/nginx/paginaweb.access.log;

location / {
root /var/www/paginaweb.com;
index index.php;
if (-e $request_filename) {
break;
}
rewrite ^/(.+)$ /index.php?/$1 last;
}
}

Y listo, reiniciamos el servidor web.

Linux: sudo: unable to resolve host NombreMaquina

Si estas utilizando Linux ( Debian, Ubuntu u otra distro) y le cambiaste el nombre a tu maquina en el archivo /etc/hostname y después cuando quieres hacer un sudo su – te aparece:

sudo: unable to resolve host NombreMaquina

Entonces te falto cambiar también la lista de hosts con el nombre de la maquina.
Solo es entrar al archivo: /etc/hosts, con tu editor favorito (a mi me gusta nano), buscar donde dice 127.0.1.1 NombreMaquinaViejita y cambiar el nombre de la maquina por la nueva y listo!…, algo así debe de quedar:

127.0.0.1 localhost
127.0.1.1 NombreMaquina

# The following lines are desirable for IPv6 capable host

Gnome3 – Ubuntu: En donde esta el boton de apagar

Si ya tienes Gnome3, porque Unity nomas no te gusto o porque eres fan de Gnome, y quieres apagar tu computadora, logicamente te vas a la barrita superior derecha, donde esta tu nombre (como en todos los gnome o unity) le das click y ahí debe de aparecer “Apagar el equipo” pero nada de nada!.., solo ves, Bloquear pantalla, Cerrar sesión, Suspender, pero Apagar ni sus luces.

Solo debes de presionar la tecla ALT y cambiará donde dice suspender por apagar, algo extraño y no se donde se ponga por default apagar pero bueno!, ya no tenemos que cerrar sesión y luego apagar.

Apagar ya con la tecla ALT presionada

Cosas del Gnome3…..,

Me dicen que todo es una conspiración de bubulUbuntu, porque en Fedora si aparece normal!..,

Fuente: Investigando Ubuntu + mi comprobación que funciona todo OK

mcrypt: Error al cargar el modulo php_mcrypt en windows

Estoy utilizando Ushahidi en un servidor apache-php5 en windows, con AppServ, el problema esta que me dice que requiere la libreria php_mcrypt para funcionar, y pues entro a php.ini, busco la linea donde dice: extension=php_mcrypt.dll y descomento la linea, reinicio el servicio con apache_servicefix.bat dentro de la carpeta c:/AppServ/Apache2.2/ pero el problema sigue.

Revisando el log de apache veo el siguiente error:

PHP Warning: PHP Startup: Unable to load dynamic library ‘C:/AppServ\\php5\\ext\\php_mcrypt.dll’ – No se puede encontrar el m\xf3dulo especificado.\r\n in Unknown on line 0

La solución esta en copiar el archivo libmcrypt.dll que esta dentro de c:/appserv/php5/libmcrypt.dll a c:/AppServ/Apache2.2/bin/ reiniciar el servicio y listo!.., ya tenemos correctamente instalada la libreria MCrypt de PHP